Welcome to Wowza Status

Here you will find real-time information about the status of our services. Our platform is continuously monitored for outages, slowdowns, or other issues. Should there be any interruptions in service, we will provide status updates here.



 

Wowza Customer Service Email is Down

Resolved
Operational
Started about 1 year ago Lasted 20 minutes

Affected

wowza.com
My Account
Updates
  • Resolved
    Resolved

    We implemented a fix and customerservice@wowza.com email address is working as expected.

  • Investigating
    Investigating

    Wowza Customer Service email is down:
    customerservice@wowza.com.

    We are currently investigating this incident. The current workaround is to reach out to Wowza Support at wowza.com -> My Account -> Support

    This then will be redirected to Customer Service.

    More updates to follow.