Welcome to Wowza Status

Here you will find real-time information about the status of our services. Our platform is continuously monitored for outages, slowdowns, or other issues. Should there be any interruptions in service, we will provide status updates here.



 

Incident with customerservice@wowza.com receiving email

Resolved
Operational
Started 2 months ago Lasted 34 minutes

Affected

wowza.com
My Account
Updates
  • Resolved
    Resolved

    We’re happy to report a fix was deployed and was successful. This incident has been closed. Our apologies for any inconvenience this may have caused. If you experience any issues going forward, please contact Wowza Support.

  • Investigating
    Investigating

    We are actively investigating this issue.
    Known Impact: You will be unable to send an email to customerservice@wowza.com to create an account-related case.
    Workaround: Submit a request via this Customer Experience Form
    We apologize for any inconvenience this may be causing; we will provide updates here as they become available.